summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQue Quotion2019-03-20 23:30:46 +0900
committerQue Quotion2019-03-20 23:30:46 +0900
commitbc9e64e9ba5c91c685bc6b4f6cb9b3e7612b7595 (patch)
tree9cd64b357e5847ddac5b3f9f00ad068035ba7953 /PKGBUILD
parentef3903d1421c875fe41d295a8d7fe64467d5ed4e (diff)
downloadaur-bc9e64e9ba5c91c685bc6b4f6cb9b3e7612b7595.tar.gz
Update ubuntu version number; use _ instead of +; explain notify-notification-close.patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 461a5fe09fee..05e23cd87151 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
# Contributor: Adria Arrufat <adria DOT arrufat+aur AT protonmail DOT ch>
pkgname=gnome-settings-daemon-elementary
-pkgver=3.28.1+0ubuntu1+r3.6975d1c25
-pkgrel=2
+pkgver=3.28.1_0ubuntu1.1_r5.9610af6df
+pkgrel=1
pkgdesc="GNOME Settings Daemon (with elementary OS patches)"
url="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
arch=('i686' 'x86_64')
@@ -28,12 +28,14 @@ sha512sums=('SKIP'
pkgver() {
cd "os-patches"
- printf "3.28.1+0ubuntu1+r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+ printf "3.28.1_0ubuntu1.1_r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd "os-patches"
+ #https://gitlab.gnome.org/GNOME/gnome-settings-daemon/commit/3110457f72f70b2d283c1ad2f27b91b95d75d92f
patch -Np2 < ../notify-notification-close.patch
git submodule init
@@ -43,6 +45,7 @@ prepare() {
build() {
cd "os-patches"
+
[ -d build ] && rm -rf build
arch-meson build -Dstatic-false=true
ninja -C build