summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdriaan Zonnenberg2017-04-09 00:19:43 +0200
committerAdriaan Zonnenberg2017-04-09 00:19:43 +0200
commit24f0cc3ca1479e5d2ca4ed116b5864e0fe9f0b69 (patch)
tree24f4e8459ac3c68c59ce56e166fb69b6ca759f4a /PKGBUILD
parent2b6171b53d6334cce24a73b6b373f8cfeb198f1b (diff)
downloadaur-24f0cc3ca1479e5d2ca4ed116b5864e0fe9f0b69.tar.gz
Don't try to apply the patch if it's already applied
This fixes the issue described by @halomal
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ee791b44d91..16ad75004a44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,9 +17,10 @@ provides=(gnome-settings-daemon)
conflicts=(gnome-settings-daemon)
groups=(gnome)
_commit=239ccb035d17380d801d9cdde3a10dce5b64ac85 # tags/GNOME_SETTINGS_DAEMON_3_22_2^0
+_patch='gsd-3.22-color-Add-ability-to-change-the-color-temperature-of.patch'
source=("git+https://git.gnome.org/browse/gnome-settings-daemon#commit=$_commit"
"git+https://git.gnome.org/browse/libgnome-volume-control"
- "https://raw.githubusercontent.com/benzea/gnome-shell-extension-redshift/master/patches/gsd-3.22-color-Add-ability-to-change-the-color-temperature-of.patch")
+ "https://raw.githubusercontent.com/benzea/gnome-shell-extension-redshift/master/patches/$_patch")
sha256sums=('SKIP'
'SKIP'
'SKIP')
@@ -36,7 +37,7 @@ prepare() {
git config --local submodule."panels/media-keys/gvc".url "$srcdir/libgnome-volume-control"
git submodule update
- git apply ../gsd-3.22-color-Add-ability-to-change-the-color-temperature-of.patch
+ git apply --check "../$_patch" && git apply "../$_patch"
NOCONFIGURE=1 ./autogen.sh
}