summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex2019-11-26 21:44:38 +0100
committerAlex2019-11-26 21:44:38 +0100
commitda6f14d6578c1c1e7e68a7e06623f8171f514a44 (patch)
treed51f682c2d6d0fa05ddc49a3fd32cb8202018798 /PKGBUILD
downloadaur-da6f14d6578c1c1e7e68a7e06623f8171f514a44.tar.gz
First push
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06d506f9a03d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Alex S. shantanna_at_hotmail_dot_com>
+
+pkgname=gnome-shell-extension-animation-tweaks-git
+_pkgname=Animation-Tweaks
+pkgver=8.482f1ab
+pkgrel=1
+pkgdesc="A GNOME Shell Extension to Tweak animations and customize them."
+arch=('any')
+url="https://github.com/Selenium-H/Animation-Tweaks"
+license=('GLPv3')
+depends=('gnome-shell')
+makedepends=('git')
+source=('git+https://github.com/Selenium-H/Animation-Tweaks.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ echo $(grep '^Version ' README.md | cut -d' ' -f2).$(git describe --always --tags)
+}
+
+package() {
+ _extid='animation-tweaks@Selenium-H'
+ cd "${srcdir}/${_pkgname}"
+
+ cp -af schemas "${_extid}"
+ cp -af locale "${_extid}"
+
+ glib-compile-schemas "${_extid}/schemas"
+ rm -rf "${_extid}/schemas/"*.xml
+
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions"
+ cp -af "${_extid}" "${pkgdir}/usr/share/gnome-shell/extensions/"
+}