summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Schendel2020-12-16 04:19:16 +0100
committerChristian Schendel2020-12-16 04:19:16 +0100
commitb66b750c0ec57847cf78e3b86f0a19cffde76b7c (patch)
tree83d4442b5578c9d8e6dac3e469eaf86575d085e5 /PKGBUILD
parent182bdab7c8b14bfcb6f186fc692f9dd2c9be672e (diff)
downloadaur-b66b750c0ec57847cf78e3b86f0a19cffde76b7c.tar.gz
add glib2 to makedepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8641e91ca32e..60459870b3e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,6 +9,7 @@ url="https://github.com/RaphaelRochet/applications-overview-tooltip"
install=${pkgname%-git}.install
license=('GPL')
depends=('gnome-shell>=3.38')
+makedepends=('git' 'glib2')
conflicts=("${pkgname%-git}")
provides=(${pkgname%-git})
source=("${pkgname%-git}::git+https://github.com/RaphaelRochet/applications-overview-tooltip.git#commit=$_commit")
@@ -26,7 +27,7 @@ package() {
install -d "${pkgdir}/usr/share/gnome-shell/extensions/"
mv ${pkgname%-git} ${_uuid}
cp -r "${_uuid}" "${pkgdir}/usr/share/gnome-shell/extensions/"
- #rebuild compiled schemas if missimg
+ #rebuild compiled schemas if missing
if [[ ! -f "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/schemas/gschemas.compiled" ]]; then
glib-compile-schemas ${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/schemas
fi