summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLlewelyn Trahaearn2018-08-10 16:37:13 -0700
committerLlewelyn Trahaearn2018-08-10 16:37:13 -0700
commit0e873ed57ccfa57aeaaa351dd2d0c3ef665c7a32 (patch)
tree61d7170c81a78f1140415a1ef260c60d9cc20910 /PKGBUILD
parent1235ed5a674547c0e6330ac5fa9a9be41e85de85 (diff)
downloadaur-0e873ed57ccfa57aeaaa351dd2d0c3ef665c7a32.tar.gz
Remove hard coded assumption of extension source location.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04ddd61b4508..fb4c00f8da8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,8 @@ sha512sums=('aedb0f6b710333d9c5bc474265ad17e181608141e8e2ada504a1f13334bd01abaf2
package() {
- cd "arch-update-${pkgver}"
# Locate the extension.
+ cd "$(dirname $(find -name 'metadata.json' -print -quit))"
_extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
_destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"
# Copy extension files into place.