summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjonian2021-04-28 13:40:47 +0300
committerjonian2021-04-28 13:40:47 +0300
commita6d02092f992ee5c96e6cf55e7a292e59ab809b9 (patch)
tree86ec5b71f1188fb83819b0f9143672497de9b163 /PKGBUILD
downloadaur-a6d02092f992ee5c96e6cf55e7a292e59ab809b9.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8bf3d2adaa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jonian Guveli <https://github.com/jonian/>
+_uuid="bluetooth-quick-connect@bjarosze.gmail.com"
+_repo="gnome-bluetooth-quick-connect"
+pkgname=gnome-shell-extension-bluetooth-quick-connect
+pkgver=19
+pkgrel=1
+pkgdesc="Allow to connect bluetooth paired devices from gnome control panel."
+arch=("any")
+url="https://github.com/bjarosze/$_repo"
+license=("GPL")
+depends=("gnome-shell" "bluez-utils")
+conflicts=("$pkgname-git")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+md5sums=("730f093f6f29d1b9a2757767357200b4")
+
+package() {
+ glib-compile-schemas "$srcdir/$_repo-$pkgver/schemas"
+
+ install -d "$pkgdir/usr/share/gnome-shell/extensions" \
+ && cp -a "$srcdir/$_repo-$pkgver/." "$_/$_uuid"
+
+ install -d "$pkgdir/usr/share/glib-2.0" \
+ && cp -a "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/schemas" "$_"
+
+ rm -f "$pkgdir/usr/share/glib-2.0/schemas/gschemas.compiled"
+}