summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Donat2016-11-20 19:51:55 +0100
committerMichal Donat2016-11-20 19:51:55 +0100
commitce8c93de4a18dd488b57e5672e9bafc43727f7d4 (patch)
treee6082bb776917807079d610f30042750488ca93a /PKGBUILD
downloadaur-gnome-shell-extension-calc-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..381ae9a8ceb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Michal DonĂ¡t <michal at donat dot cz>
+pkgname=gnome-shell-extension-calc-git
+_pkgname=gnome-shell-calculator
+pkgver=r10.26c8c65
+pkgrel=1
+pkgdesc="Simple gnome shell calculator in run dialog that you can use with alt+f2"
+arch=('any')
+url="https://github.com/danigm/gnome-shell-calculator"
+license=('GPL2')
+depends=('gnome-shell')
+makedepends=('git')
+install='gschemas.install'
+source=("git+https://github.com/danigm/gnome-shell-calculator")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ for i in $(find -type f); do
+ install -Dm 644 "$i" "${pkgdir}/usr/share/gnome-shell/extensions/calc@danigm.wadobo.com/${i}"
+ done
+}