summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPieter Goetschalckx2019-05-15 14:28:05 +0200
committerPieter Goetschalckx2019-05-15 14:28:05 +0200
commitfd787ab8ca9ecb0c915ddfee3ff58976bbd24ed0 (patch)
tree12ba6de251c1feaba7e195d1d0b002f82b670e59 /PKGBUILD
parent591aa7d158aa441338cf55a225c9a18495d9c18e (diff)
downloadaur-fd787ab8ca9ecb0c915ddfee3ff58976bbd24ed0.tar.gz
v9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a0cfab74b9c..ad243a44cdcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,19 @@
# Maintainer: Pieter Goetschalckx <3.14.e.ter <at> gmail <dot> com>
pkgname=gnome-shell-extension-cast-to-tv
-pkgver=8
+pkgver=9
pkgrel=1
pkgdesc="Cast files to your Chromecast or other devices over local network"
arch=('any')
url="https://github.com/Rafostar/$pkgname"
license=('GPL')
depends=('gnome-shell' 'ffmpeg')
+optdepends=(
+ 'python-nautilus: Nautilus integration'
+)
makedepends=('npm' 'gettext')
source=("https://github.com/Rafostar/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('1c37ea56c9d38950016d8a469e7ee13ff342e6773b6793d2ded0cc1bd118d48e')
+sha256sums=('b67df23d85de7feb779cda4872e54a59b521e789a7183f60f5fdd297dcc746db')
build() {
cd "$pkgname-$pkgver"
@@ -24,11 +27,14 @@ package() {
uuid="cast-to-tv@rafostar.github.com"
install -dm755 "$pkgdir/usr/share/gnome-shell/extensions/$uuid"
- cp -r *.js *.json webplayer "$pkgdir/usr/share/gnome-shell/extensions/$uuid/"
+ install -dm777 "$pkgdir/usr/share/gnome-shell/extensions/$uuid/config"
+ cp -r *.js *.json appIcon node_scripts webplayer "$pkgdir/usr/share/gnome-shell/extensions/$uuid/"
install -dm755 "$pkgdir/usr/share/locale"
cp -r locale/* "$pkgdir/usr/share/locale/"
install -Dm644 "schemas/org.gnome.shell.extensions.cast-to-tv.gschema.xml" \
"$pkgdir/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.cast-to-tv.gschema.xml"
+
+ install -Dm644 nautilus/nautilus-cast-to-tv.py -t "$pkgdir/usr/share/nautilus-python/extensions/"
}