summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorinfinitebash2023-04-14 15:28:40 -0700
committerinfinitebash2023-04-14 15:28:40 -0700
commite9f6714479870515ddbb8a3d843f001393f209cb (patch)
tree5d035aaa98fafda986b044f031fedd072b4693e8 /PKGBUILD
downloadaur-e9f6714479870515ddbb8a3d843f001393f209cb.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99919223a361
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: infinitebash <aur at infinitebash dot com>
+_pkgname="gnome-shell-extension-colorblind-filters"
+pkgname="${_pkgname}-git"
+_uuid="colorblind-filters@G-dH.github.com"
+pkgver=r51.4a0147c
+pkgrel=1
+pkgdesc="A GNOME Shell extension for main panel that offers full-screen color filters that should help color-blind users and developers."
+arch=(any)
+url="https://github.com/G-dH/gnome-colorblind-filters"
+license=('GPLv3')
+depends=(gnome-desktop)
+makedepends=(git make zip unzip)
+provides=(gnome-colorblind-filters)
+source=("${_pkgname}::git+https://github.com/G-dH/gnome-colorblind-filters")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make zip
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/gnome-shell/extensions/$_uuid
+ cd ${pkgdir}/usr/share/gnome-shell/extensions/$_uuid
+ unzip "${srcdir}/${_pkgname}/$_uuid.zip"
+}