summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicola Murino2017-09-24 08:23:59 +0200
committerNicola Murino2017-09-24 08:23:59 +0200
commit4e144939cd484499e3bd23b532627ed4bea1ed46 (patch)
tree73711f97a86b63af36c063069ef054eaad180df9 /PKGBUILD
parent4058bfa8179851386526b0d34660507fea87aa76 (diff)
downloadaur-4e144939cd484499e3bd23b532627ed4bea1ed46.tar.gz
updated to v61
simplified PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD92
1 files changed, 15 insertions, 77 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac4cac055a68..f728ccb4c4f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,92 +1,30 @@
-# Maintainer: XZS <d dot f dot fischer at web dot de>
+# Maintainer: drakkan <nicola dot murino at gmail dot com>
+# Contributor: XZS <d dot f dot fischer at web dot de>
# Contributor: Carl George < arch at cgtx dot us >
# Contributor: Janne Haapsaari <haaja@iki.fi>
# Contributor: Christopher Krooß <didi2002 at web.de>
-# This PKGBUILD is maintained on GitHub <https://github.com/dffischer/gnome-shell-extensions>.
-# You may find it convenient to file issues and pull requests there.
pkgname=gnome-shell-extension-dash-to-dock
-pkgver=60
+_pkgname=dash-to-dock-extensions.gnome.org-v
+pkgver=61
pkgrel=1
-pkgdesc="move the dash out of the overview transforming it in a dock"
+pkgdesc="Move the dash out of the overview transforming it in a dock"
arch=('any')
url="https://micheleg.github.io/dash-to-dock/"
license=('GPL')
-depends=('dconf')
-makedepends=('intltool')
-source=("https://micheleg.github.io/dash-to-dock/releases.html")
-md5sums=('SKIP')
+depends=('gnome-shell')
+makedepends=('intltool' 'gettext')
+source=("https://github.com/micheleg/dash-to-dock/archive/extensions.gnome.org-v${pkgver}.tar.gz")
+sha256sums=('8cea499749cca5cc0ae248a9ae5b1cda7e364526d5d1d90fd71f6aa886837c51')
-pkgver() {
- grep -Pom1 '(?<=Version )[[:digit:]]+' releases.html
-}
-
-prepare() {
- if [ ! -f *.shell-extension.zip ]; then
- curl -OL $(grep -om1 \
- 'https://extensions.gnome.org/.*/[[:digit:]]\+.shell-extension.zip' \
- releases.html)
- fi
- unzip -o *.shell-extension.zip
+build() {
+ cd "${srcdir}"/${_pkgname}${pkgver}
+ make
}
package() {
- for function in $(declare -F | grep -Po 'package_[[:digit:]]+[[:alpha:]_]*$')
- do
- $function
- done
-}
-package_01_locate() {
- msg2 'Locating extension...'
- cd "$(find -name 'metadata.json' -execdir test -e extension.js \; \
- -printf '%C@ %h\n' | sort -nr | sed 's/^.* //;q' )"
- extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
- destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
-}
-
-package_02_install() {
- msg2 'Installing extension code...'
- find -maxdepth 1 \( -iname '*.js*' -or -iname '*.css' -or -iname '*.ui' \) \
- -exec install -Dm644 -t "$destdir" '{}' +
-}
-
-package_09_media() {
- cp -r --no-preserve=ownership,mode media "$destdir"
-}
-
-package_10_locale() {
- msg2 'Installing translations...'
- (
- cd locale
- for locale in */
- do
- install -Dm644 -t "$pkgdir/usr/share/locale/$locale/LC_MESSAGES" "$locale/LC_MESSAGES"/*.mo
- done
- )
+ cd "${srcdir}"/${_pkgname}${pkgver}
+ make DESTDIR="${pkgdir}" VERSION="${pkgver}" install
}
-if [ -z "$install" ]
-then
- install=gschemas.install
-fi
-package_10_schemas() {
- msg2 'Installing schemas...'
- find -name '*.xml' -exec install -Dm644 -t "$pkgdir/usr/share/glib-2.0/schemas" '{}' +
-}
-depends[125]=gnome-shell
-
-package_20_version() {
- local compatibles=($(\
- find -path ./pkg -type d -prune -o \
- -name metadata.json -exec cat '{}' \; | \
- tr -d '\n' | grep -Po '(?<="shell-version": \[)[^\[\]]*(?=\])' | \
- tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
- depends+=("gnome-shell>=3.${compatibles[0]}")
- local max="${compatibles[-1]}"
- if [ "$max" != $(
- gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+'
- ) ]; then
- depends+=("gnome-shell<3.$((${max%%.*} + 1))")
- fi
- unset depends[125]
-}
+# vim:set ts=2 sw=2 et: