summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcarl.george2015-07-10 12:50:08 -0500
committercarl.george2015-07-10 12:50:08 -0500
commite491eeda0045095596b85197bc189b2e89ea336c (patch)
tree91bb1b51e4ae2ad45e905a9104bcee6a1bc95100 /PKGBUILD
downloadaur-e491eeda0045095596b85197bc189b2e89ea336c.tar.gz
initial import from legacy AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38a415499da3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Janne Haapsaari <haaja@iki.fi>
+# Contributor: Christopher Krooß <didi2002 at web.de>
+pkgname=gnome-shell-extension-dash-to-dock
+pkgver=v46
+pkgrel=2
+pkgdesc="A gnome-shell extension that transforms the dash into an intellihide dock"
+arch=('any')
+url="https://github.com/micheleg/dash-to-dock"
+license=('GPL')
+depends=('dconf')
+makedepends=('gnome-common' 'intltool')
+provides=('gnome-shell-extension-dash-to-dock')
+conflicts=('gnome-shell-extensions-dash-to-dock-git')
+source=("$pkgname::https://github.com/micheleg/dash-to-dock/archive/extensions.gnome.org-${pkgver}.tar.gz")
+md5sums=('f085cee5b4373029a00d7987081d1d5d')
+install='gschemas.install'
+
+_archivename="dash-to-dock-extensions.gnome.org-${pkgver}"
+
+prepare() {
+ cd "$srcdir/$_archivename"
+ sed -i 's/INSTALLBASE = ~\/.local\/share\/gnome-shell\/extensions/INSTALLBASE = ${DESTDIR}/'\
+ Makefile
+}
+
+build() {
+ cd "$srcdir/$_archivename"
+ make
+}
+
+package() {
+ cd "$srcdir/$_archivename"
+ mkdir -p "${pkgdir}/usr/share/gnome-shell/extensions" "${pkgdir}/usr/share/glib-2.0/schemas/"
+ make DESTDIR=${pkgdir}/usr/share/gnome-shell/extensions install
+ install -m644 "schemas/org.gnome.shell.extensions.dash-to-dock.gschema.xml" \
+ "${pkgdir}/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.dash-to-dock.gschema.xml"
+}