summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-04-22 11:51:36 +0200
committerXZS2016-04-22 11:51:36 +0200
commitf3843c46789b507df5b7dd6dcc01c3cca6e078bf (patch)
treeb2d2b0d85a3fc56c1c00c5ce47d2616ddc34c2f5 /PKGBUILD
parent82953166daa452b8915209b3112cd0b4d7ef2162 (diff)
downloadaur-f3843c46789b507df5b7dd6dcc01c3cca6e078bf.tar.gz
fix version comparison
Comparing the minor version to a string of minor and major will never succeed. Originally, a restriction on the current shell version was omitted for historical reasons - most packages did so when dependencies were defined manually. This now turns into a concious decision to - permit the usage of the extension in instable gnome-shell versions - the ones with odd minor version numbers - where incompatibilities are introduced gradually. - ease the transition from one stable gnome-shell version - the ones with even minor version numbers - to the next. In an ideal world, all extensions should have been updates before the update hits the repositories. But as Arch is quite more on the edge than developers of some of the extensions, this is not the case more often than not.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index efe002295988..9b8cadb855c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -81,7 +81,7 @@ package_20_version() {
tr '\n," ' '\n' | sed 's/3\.//g;/^$/d' | sort -n -t. -k 1,1))
depends+=("gnome-shell>=3.${compatibles[0]}")
local max="${compatibles[-1]}"
- if [ "3.$max" != $(
+ if [ "$max" != $(
gnome-shell --version | grep -Po '(?<=GNOME Shell 3\.)[[:digit:]]+'
) ]; then
depends+=("gnome-shell<3.$((${max%%.*} + 1))")