summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2015-12-06 21:06:44 +0100
committerXZS2015-12-06 21:06:44 +0100
commit9dec3e5adff0e0ce168eca3a04e99b89c0e54396 (patch)
treee8cc3779c0a722e772e77f509331a1a98b1da646 /PKGBUILD
parent7aec441a9bac7f3b26ab34b73e167946bb0d6f15 (diff)
downloadaur-9dec3e5adff0e0ce168eca3a04e99b89c0e54396.tar.gz
patch up unreadable image
Due to a bug with librsvg[1] GTK is unable to process the image logo.svg. As ImageMagic still can handle it without any hiccups, it can be converted to a PNG before GTK ever sees it until the bug is fixed. [1]: https://bugs.archlinux.org/index.php?do=details&task_id=47245
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 9 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3a1227db5fe..3b5b2f1bf3dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,6 +28,15 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$_gitname"
+ grep -lZr logo.svg | while IFS= read -rd $'\0' file
+ do
+ sed -i 's/\(logo\.\)svg/\1png/' "$file"
+ done
+ convert media/logo.{svg,png}
+}
+
build() {
cd "$_gitname"
make _build