diff options
author | XZS | 2019-11-14 01:27:31 +0100 |
---|---|---|
committer | XZS | 2019-11-14 01:27:31 +0100 |
commit | a58f216de8193bcf18158296e06c1119250a58ee (patch) | |
tree | 96dfc55dc0a9439c4b6a17e4ff8bcc285534a2c3 /PKGBUILD | |
parent | 3d4e471554087543e9ef3a8683a7e622bc03b9d8 (diff) | |
download | aur-a58f216de8193bcf18158296e06c1119250a58ee.tar.gz |
restore compilation with Pacman 5.2
Since Pacman version 5.2.0 makepkg exits whenever any command in a
pkgver function returns a non-zero exit code. A recent correction from
the git-makepkg-templates [1] adapts to this, restoring correct
processing of the PKGBUILD.
As this concern only the build process, not changing any of the
resulting package content, the pkgrel is kept constant, to avoid
triggering any unnecessary rebuild.
[1]: https://github.com/dffischer/git-makepkg-templates/commit/d91fca9b16dd03bc0bf924dbd95dd24b06e232fe
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -28,7 +28,7 @@ conflicts+=("$_gitname") pkgver() { cd ${_gitname:-$pkgname} git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1' - [ ${PIPESTATUS[0]} -ne 0 ] && \ + [ ${PIPESTATUS[0]} -eq 0 ] || \ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" } |