summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcarlwgeorge2017-01-08 12:50:58 -0600
committercarlwgeorge2017-01-08 12:50:58 -0600
commit0062fccc36c0f7be842eeace3c3033b8b40ff55c (patch)
treeb6f379cfad88e890a6059f66dc580c38989f7f91 /PKGBUILD
downloadaur-0062fccc36c0f7be842eeace3c3033b8b40ff55c.tar.gz
initial package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1c95e238a39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Carl George < arch at cgtx dot us >
+
+pkgname=gnome-shell-extension-dash-to-panel-git
+pkgver=r45.b34c092
+pkgrel=1
+pkgdesc='Extension for GNOME shell to combine the dash and main panel'
+arch=(any)
+_githubname=dash-to-panel
+_githubowner=jderose9
+url="https://github.com/${_githubowner}/${_githubname}"
+license=(GPL2)
+depends=('gnome-shell>=3.18')
+makedepends=(git gnome-common intltool)
+source=("git+https://github.com/${_githubowner}/${_githubname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_githubname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_githubname}"
+ make VERSION="$pkgver" _build
+}
+
+package() {
+ cd "${srcdir}/${_githubname}"
+ make DESTDIR="$pkgdir" install
+}