summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-12-09 20:59:07 +0330
committerMohammadreza Abdollahzadeh2017-12-09 20:59:07 +0330
commit4751fb90e6084a4e5cceb76faf9ab91d2dcd00f8 (patch)
tree6054af8cccaf70e8953d4235e2326c2c3c853922 /PKGBUILD
parentfe9b4d4d6fb9bb54b71abebf7c53bc308dd6284a (diff)
downloadaur-4751fb90e6084a4e5cceb76faf9ab91d2dcd00f8.tar.gz
fix PKGBUILD and change versioning number
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 337d885d663b..e0b093e189a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Carl George < arch at cgtx dot us >
pkgname=gnome-shell-extension-dash-to-panel-git
-pkgver=r262.187ac72
+pkgver=11.r23.g9b5f264
pkgrel=1
pkgdesc='Extension for GNOME shell to combine the dash and main panel'
arch=(any)
@@ -12,14 +12,16 @@ _githubowner=jderose9
url="https://github.com/${_githubowner}/${_githubname}"
license=(GPL2)
depends=('gnome-shell>=3.18')
-makedepends=(git gnome-common intltool)
+makedepends=('git' 'gnome-common' 'intltool')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
install='gnome-shell-extension.install'
source=("git+${url}.git")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_githubname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {