summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntiz (Robin C.)2022-12-08 14:44:13 +0100
committerAntiz (Robin C.)2022-12-08 14:44:13 +0100
commit658ca42e2beaf4b8da12f4c7de4462b4cb036779 (patch)
tree3590b5cd5becfd32df643c3188f43894dcc2f27a /PKGBUILD
parent74f72ea6edcb02c0b3ba314e549f1c67e033eb62 (diff)
downloadaur-658ca42e2beaf4b8da12f4c7de4462b4cb036779.tar.gz
Various improvements to the PKGBUILD + Removed (post)install script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce5c6cd4ec78..116ac986fb7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
+# Maintainer: Robin Candau <robincandau[at]protonmail[dot]com>
+# Contributor: Matrix <thysupremematrix a_t tuta d_o_t io>
# Contributor: Yamada Hayao <hayao@fascode.net>
-# Maintainer: Matrix <thysupremematrix a_t tuta d_o_t io>
-_extname='desktop-icons-ng'
-pkgname="gnome-shell-extension-desktop-icons-ng"
-pkgver="47"
-pkgrel=3
+pkgname=gnome-shell-extension-desktop-icons-ng
+_pkgname=desktop-icons-ng
+pkgver=47
+pkgrel=4
pkgdesc="A fork from the official desktop icons project, with several enhancements like Drag'n'Drop."
-arch=('x86_64' 'i686')
-url="https://gitlab.com/rastersoft/desktop-icons-ng/"
+arch=('x86_64' 'i686' 'aarch64')
+url="https://gitlab.com/rastersoft/desktop-icons-ng"
license=('GPL3')
depends=('gnome-shell>=3.38')
-makedepends=('git' 'meson' 'glib2')
-conflicts=("$pkgname-git")
-source=("$_extname-$pkgver.tar.gz::https://gitlab.com/rastersoft/$_extname/-/archive/$pkgver/$_extname-$pkgver.tar.gz")
-install="gnome-shell-extension.install"
-sha512sums=('a52131e89b54a7d7400bb0269403dbee7e5173347863721f8191a0e3b6fde7bdc3f83ee8bd71b132191e170566e237704645bb71ef3cd748a350ab60f09deb33')
+makedepends=('meson' 'glib2')
+source=("${_pkgname}-${pkgver}::${url}/-/archive/${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('520ae7bc4dfed49aaa17e379f21b694c51ffc789daad058c3b8617e02e4d0e24')
build() {
- arch-meson desktop-icons-ng-$pkgver build
- meson compile -C build
+ arch-meson "${_pkgname}-${pkgver}" build
+ meson compile -C build
}
package() {
- meson install -C build --destdir "$pkgdir"
+ meson install -C build --destdir "${pkgdir}"
}