summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatrix2022-11-06 12:30:28 +0000
committerMatrix2022-11-06 12:30:28 +0000
commit74f72ea6edcb02c0b3ba314e549f1c67e033eb62 (patch)
treebf04f23e0311e26eb36d038618dd4a82d55d7ed6 /PKGBUILD
parentb2188115aec256c5d80fceb36d10b82bf13fa585 (diff)
downloadaur-74f72ea6edcb02c0b3ba314e549f1c67e033eb62.tar.gz
Code cleanup + Add .install file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 6 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 313774d0c527..ce5c6cd4ec78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,23 @@
_extname='desktop-icons-ng'
pkgname="gnome-shell-extension-desktop-icons-ng"
pkgver="47"
-pkgrel=2
+pkgrel=3
pkgdesc="A fork from the official desktop icons project, with several enhancements like Drag'n'Drop."
arch=('x86_64' 'i686')
url="https://gitlab.com/rastersoft/desktop-icons-ng/"
license=('GPL3')
-depends=('gnome-shell')
+depends=('gnome-shell>=3.38')
makedepends=('git' 'meson' 'glib2')
conflicts=("$pkgname-git")
source=("$_extname-$pkgver.tar.gz::https://gitlab.com/rastersoft/$_extname/-/archive/$pkgver/$_extname-$pkgver.tar.gz")
+install="gnome-shell-extension.install"
sha512sums=('a52131e89b54a7d7400bb0269403dbee7e5173347863721f8191a0e3b6fde7bdc3f83ee8bd71b132191e170566e237704645bb71ef3cd748a350ab60f09deb33')
-
-
build() {
- cd $srcdir/$_extname-$pkgver/
- _uuid=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
-
- DESTDIR="$pkgdir/usr" meson --prefix="$srcdir/$_extname-$pkgver/$_uuid" --localedir=locale "build" "."
- cd build
- meson install
+ arch-meson desktop-icons-ng-$pkgver build
+ meson compile -C build
}
package() {
- cd $srcdir/$_extname-$pkgver/
- _uuid=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
-
- install -dm755 "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
-
- cd $srcdir/$_extname-$pkgver/$_uuid
- cp -dpr --no-preserve=ownership ./* "${pkgdir}/usr/"
- mv $pkgdir/usr/locale $pkgdir/usr/share/gnome-shell/extensions/$_uuid/locale
- rm $pkgdir/usr/share/glib-2.0/schemas/gschemas.compiled
+ meson install -C build --destdir "$pkgdir"
}