summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfrancoism902022-09-18 12:28:43 +0200
committerfrancoism902022-09-18 12:28:43 +0200
commitc223a4441b76400edc3372ffecb0618d7c60e804 (patch)
treea9f40b6546a2d33e1e95cb9219546b3be1437ad2 /PKGBUILD
downloadaur-c223a4441b76400edc3372ffecb0618d7c60e804.tar.gz
Init package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e679b31223b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Francois Menning <f.menning@pm.me>
+# Contributer: Tony Lambiris <tony@libpcap.net>
+
+pkgname=gnome-shell-extension-espresso
+pkgver=7
+pkgrel=1
+pkgdesc="Prevent auto suspend and screensaver functions (forked from caffeine)"
+arch=('any')
+url="https://github.com/coadmunkee/gnome-shell-extension-espresso.git"
+install=espresso.install
+license=('GPL2')
+depends=('gnome-shell')
+makedepends=('git')
+source=("${pkgname}::git+${url}#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ ./update-locale.sh
+
+ glib-compile-schemas \
+ --targetdir=espresso@coadmunkee.github.com/schemas/ \
+ --strict espresso@coadmunkee.github.com/schemas
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -dm755 "${pkgdir}/usr/share/gnome-shell/extensions"
+ cp -a "espresso@coadmunkee.github.com" "${pkgdir}/usr/share/gnome-shell/extensions"
+}