summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Brandt2017-01-29 21:24:36 +0000
committerStephen Brandt2017-01-29 21:24:36 +0000
commit130ee761b266c749262f0da62b8018e06fcf0bde (patch)
treebc3fd010ef78e41a4966253eec7ed8c360d30387 /PKGBUILD
downloadaur-130ee761b266c749262f0da62b8018e06fcf0bde.tar.gz
Add .SRCINFO and PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64b73e0975d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Stephen Brandt <stephen@stephenbrandt.com>
+
+pkgname=gnome-shell-extension-haguichi-indicator-git
+_gitname=gse-haguichi-indicator
+_uuid='gse-haguichi-indicator@ztefn.github.com'
+pkgver=r15.2596e0b
+pkgrel=1
+pkgdesc="Let's you control Haguichi directly from the system status area in GNOME Shell."
+arch=('any')
+url="https://github.com/ztefn/$_gitname"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('git')
+provides=('gnome-shell-extension-haguichi-indicator')
+conflicts=('gnome-shell-extension-haguichi-indicator')
+source=("git+$url")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ mkdir -p "$pkgdir/usr/share/gnome-shell/extensions/"
+ cp -R "$_uuid" "$pkgdir/usr/share/gnome-shell/extensions"
+}