summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIgor Dyatlov2021-09-03 21:03:31 +0300
committerIgor Dyatlov2021-09-03 21:03:31 +0300
commitc2ac37f896e1c0ac899402cc6a70cae2e1e2aa7f (patch)
treeb5038a66e35353437b94838c34779239440a057c /PKGBUILD
downloadaur-c2ac37f896e1c0ac899402cc6a70cae2e1e2aa7f.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02c011eba00d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=gnome-shell-extension-hibernate
+_pkgname=gnome-shell-hibernate-extension
+pkgver=7
+pkgrel=1
+pkgdesc="A GNOME extension that adds the option to hibernate amongst other system actions"
+arch=('any')
+url="https://codeberg.org/kiyui/gnome-shell-hibernate-extension"
+license=('GPL2')
+depends=('gnome-shell' 'gnome-shell-extensions')
+makedepends=('meson')
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=('4232980e25cf156c4425c48f696dbaae6f6998a2877a9c6bbf6215ad4db58c66')
+
+build() {
+ arch-meson $_pkgname build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}