summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-10-11 11:37:04 -0600
committerMark Wagie2020-10-11 11:37:04 -0600
commit375d1c6c53a1b7f0c822ef3942cf86dc6db06378 (patch)
tree91453053be84c19c94f3a1132fcde1dc1f0af917 /PKGBUILD
parent19d2835d854e9a23c225eb4f7be79e070daf981e (diff)
downloadaur-375d1c6c53a1b7f0c822ef3942cf86dc6db06378.tar.gz
fix schemas
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 917fb644bee0..061452e73f23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# # Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: ryanvade
pkgname=gnome-shell-extension-hibernate-status-git
-pkgver=1.7.r1.g8d1cab6
+pkgver=1.9.r1.gc14c68d
pkgrel=1
pkgdesc="GNOME Shell extension that adds a hibernate/hybrid suspend button in Status menu."
arch=('any')
@@ -19,10 +19,19 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "$srcdir/${pkgname%-git}"
+
+ # Extension won't detected compiled schemas in /usr/share/glib-2.0/schemas
+ glib-compile-schemas schemas
+}
+
package() {
_uuid='hibernate-status@dromi'
cd "$srcdir/${pkgname%-git}"
install -Dm644 schemas/*.xml -t "$pkgdir/usr/share/glib-2.0/schemas"
- install -Dm644 *.js *.json -t "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+ install -Dm644 schemas/*.compiled -t \
+ "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/schemas"
+ install -m644 *.js *.json -t "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
}