summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Wiesner2020-05-19 13:32:03 +0200
committerSebastian Wiesner2020-05-19 13:32:03 +0200
commit96098525c6f136d3840bdc2548226719cc58b510 (patch)
treee13b33ae3f4ecb5e0008b7b2b14b56534844fcb4 /PKGBUILD
downloadaur-96098525c6f136d3840bdc2548226719cc58b510.tar.gz
Add JetBrains search provider
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37ba64077416
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Sebastian Wiesner <sebastian@swsnr.de>
+
+_uuid="jetbrains-search-provider@swsnr.de"
+pkgname=gnome-shell-extension-jetbrains-search-provider
+pkgver=1
+pkgrel=1
+pkgdesc="Add recent projects from JetBrains IDEs to Gnome Shell search"
+arch=('any')
+url="https://github.com/lunaryorn/jetbrains-search-provider/"
+license=('Apache')
+depends=('gnome-shell>=3.36' 'python>=3.6')
+source=("$url/releases/download/v$pkgver/${_uuid}.shell-extension.zip")
+md5sums=('bb2f40d30565fb413d75762b9dbe307d')
+sha1sums=('94a1fff87039b03d98f2982c20a19eaf5849fb67')
+sha512sums=('e050b5664767f0ec6056c438ca3784ed79d43e24bcb4aab8051c775b22a997f4af54852bbbac1c472e7af064146639cc13f70660dd44804cb4e4a17af0a7c242')
+
+package() {
+ local _destdir="$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+
+ install -d "$_destdir"
+ cp --parents -t "$_destdir" -- metadata.json *.js *.py
+}