summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrliang2017-03-18 16:45:59 -0300
committerrliang2017-03-18 16:45:59 -0300
commitdf3d72d77d87d702526863a383352e0b3669f36d (patch)
treec622e8d6d8561ac9b94fc51f35d4521a830ac071 /PKGBUILD
downloadaur-gnome-shell-extension-maximize-to-workspace-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41effa4bb2e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ricardo Liang <ricardoliang at gmail dot com>
+pkgname=gnome-shell-extension-maximize-to-workspace-git
+pkgver=r4.7d86fdf
+pkgrel=1
+pkgdesc='Adds task icons grouped by workspace to the panel.'
+arch=('any')
+url="https://github.com/rliang/gnome-shell-extension-maximize-to-workspace"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('git')
+optdepends=()
+conflicts=('gnome-shell-extension-maximize-to-workspace')
+source=("${pkgname}::git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${pkgname}"
+
+ local _extname="$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)"
+
+ install -Dm644 -t "${pkgdir}/usr/share/gnome-shell/extensions/${_extname}" *.js metadata.json
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+}