summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJussi Saarinen2015-07-07 22:20:25 +0300
committerJussi Saarinen2015-07-07 22:20:25 +0300
commit415165622e7f4419ab37d343d9046366c410afbc (patch)
tree8c57445b26b183f2412a6700ffe5bacb577ec3dd /PKGBUILD
downloadaur-415165622e7f4419ab37d343d9046366c410afbc.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c2db1471f15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: jtts
+# Contributor: Christian METZLER <neroth@xeked.com>
+
+pkgname=gnome-shell-extension-openweather-git
+pkgver=r729.9d0b1b1
+pkgrel=1
+pkgdesc="A simple extension for displaying weather informations from several cities in GNOME Shell."
+arch=(any)
+url="https://github.com/jenslody/gnome-shell-extension-openweather"
+license=(GPL3)
+depends=(glib2 gettext pkg-config)
+makedepends=(git gnome-common autoconf automake intltool)
+provides=(gnome-shell-extension-weather-neroth-git
+ gnome-shell-extension-weather-git
+ gnome-shell-extension-yawe-git)
+conflicts=(gnome-shell-extension-weather-neroth-git
+ gnome-shell-extension-weather-git
+ gnome-shell-extension-yawe-git)
+install='gschemas.install'
+source=("$pkgname"::"git+https://github.com/jenslody/gnome-shell-extension-openweather#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR=$pkgdir install
+} \ No newline at end of file