summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-04-26 22:34:35 +0430
committerMohammadreza Abdollahzadeh2017-04-26 22:34:35 +0430
commitc4cd0499cda2061fee43206f86f3027f7cccb690 (patch)
tree38392b25f101e6dc4cc9d275dc3f276537d1117d /PKGBUILD
downloadaur-c4cd0499cda2061fee43206f86f3027f7cccb690.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5b512e220df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Omid Mottaghi Rad <omidmr at gmail dot com>
+# Co-Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=gnome-shell-extension-persian-calendar-git
+pkgver=r124.6729756
+pkgrel=1
+pkgdesc="Persian calendar for Gnome Shell."
+arch=(any)
+url="https://github.com/omid/Persian-Calendar-for-Gnome-Shell"
+license=(GPL3)
+depends=('gnome-shell>=3.20')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=("${pkgname%-git}")
+makedepends=(git)
+install='gnome-shell-extension.install'
+source=("${pkgname%-git}"::"git+https://github.com/omid/Persian-Calendar-for-Gnome-Shell")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/PersianCalendar@oxygenws.com"
+ cp -a $srcdir/${pkgname%-git}/* "$pkgdir/usr/share/gnome-shell/extensions/PersianCalendar@oxygenws.com"
+ rm -rf $pkgdir/usr/share/gnome-shell/extensions/PersianCalendar@oxygenws.com/.git
+}