summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTérence Clastres2019-02-11 11:10:31 +0100
committerTérence Clastres2019-02-11 11:10:31 +0100
commita53942715f27b4d99c1ec4ebf3bf449e52035408 (patch)
tree6f7a9bd15a80cc4d198c4acda9406c3b88673fcd /PKGBUILD
downloadaur-gnome-shell-extension-ping-monitor-applet-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a280c543743
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Térence Clastres <t.clastres@gmail.com>
+# Maintainer: Samuel Bachmann aka samuelba <samuel.bachmann@gmail.com>
+
+pkgname=gnome-shell-extension-ping-monitor-applet-git
+pkgver=0.0.12.r1.ga9e15be
+pkgrel=1
+pkgdesc="Ping monitor extension for Gnome-Shell"
+arch=('any')
+url="http://github.com/anybotics/gnome-shell-ping-monitor-applet"
+license=('GPL3')
+depends=('gnome-shell>=3.3.90' 'libgtop' 'networkmanager')
+makedepends=('git')
+provides=("${pkgname/-git}")
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p "$pkgdir/usr/share/gnome-shell/extensions/"
+ cp -R "ping-monitor@samuel.bachmann.gmail.com" "$pkgdir/usr/share/gnome-shell/extensions"
+}