summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2022-01-18 21:45:30 +0330
committerMohammadreza Abdollahzadeh2022-01-18 21:45:30 +0330
commit82aee5dc827f7b343b5bba38b6d699a09536efa5 (patch)
tree72d582029fa188cfcaef6cbd6c7953553b55eb4a /PKGBUILD
parent34eba4ae6623f11acd5318a27c2fbbbf9053afa9 (diff)
downloadaur-82aee5dc827f7b343b5bba38b6d699a09536efa5.tar.gz
fix PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 802226e9dd89..48a95735c47b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
-# Maintainer: M A < morealaz at gmail dot com >
-
+# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
pkgname=gnome-shell-extension-proxy-switcher-git
-pkgver=1.2.r6.g549d1aa
-pkgrel=2
+pkgver=1.4.r1.gec79104
+pkgrel=1
pkgdesc='Extension for GNOME shell to switch between the system proxy settings.'
arch=(any)
_githubname=proxy-switcher
_githubowner=tomflannaghan
url="https://github.com/${_githubowner}/${_githubname}"
license=(GPL2)
-depends=('gnome-shell>=3.18')
+depends=('gnome-shell>=3.40')
makedepends=('git' 'python')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -18,7 +17,7 @@ source=("git+${url}.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_githubname}"
+ cd "${_githubname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
@@ -27,14 +26,15 @@ prepare() {
sed -i 's|INSTALL_LOC=.*|INSTALL_LOC=$(DESTDIR)/usr/share/gnome-shell/extensions|g' \
Makefile
}
+
build() {
- cd "${srcdir}/${_githubname}"
+ cd "${_githubname}"
make build
}
package() {
- cd "${srcdir}/${_githubname}"
- install -d "$pkgdir/usr/share/gnome-shell/extensions"
- make DESTDIR="$pkgdir" install
+ cd "${_githubname}"
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions"
+ make DESTDIR="${pkgdir}" install
}
# vim:set ts=4 sw=4 et: