summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2019-01-28 20:18:41 +0330
committerMohammadreza Abdollahzadeh2019-01-28 20:18:41 +0330
commite83dc885530ca9fd0fcfe0a16f8a040877ae4c8f (patch)
treef65e5f367f863b2dc3d40272c39474f0d99fd27b /PKGBUILD
downloadaur-e83dc885530ca9fd0fcfe0a16f8a040877ae4c8f.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5902a41a71e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
+
+pkgname=gnome-shell-extension-proxy-switcher-git
+pkgver=1.2.r6.g549d1aa
+pkgrel=1
+pkgdesc='Extension for GNOME shell to switch between the system proxy settings.'
+arch=(any)
+_githubname=proxy-switcher
+_githubowner=tomflannaghan
+url="https://github.com/${_githubowner}/${_githubname}"
+license=(GPL2)
+depends=('gnome-shell>=3.18')
+makedepends=('git' 'python')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install='gnome-shell-extension.install'
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_githubname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${_githubname}"
+ sed -i 's|INSTALL_LOC=.*|INSTALL_LOC=$(DESTDIR)/usr/share/gnome-shell/extensions|g' \
+ Makefile
+}
+build() {
+ cd "${srcdir}/${_githubname}"
+ make build
+}
+
+package() {
+ cd "${srcdir}/${_githubname}"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions"
+ make DESTDIR="$pkgdir" install
+}
+# vim:set ts=2 sw=2 et: