summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-01-24 21:21:39 +0330
committerMohammadreza Abdollahzadeh2017-01-24 21:21:39 +0330
commit9cf91bdb9ede3548865b444377d40478b298ea4c (patch)
treebc759f532e151f8df442014dfae6d31fc2ddf5ec /PKGBUILD
downloadaur-9cf91bdb9ede3548865b444377d40478b298ea4c.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21296577595f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=gnome-shell-extension-radio-git
+pkgver=1.4.r25.gd6d6eb3
+pkgrel=1
+pkgdesc="Gnome shell extension for listening to internet radio streams."
+arch=(any)
+url="https://github.com/hslbck/gnome-shell-extension-radio"
+license=('GPL')
+depends=('gnome-shell>=3.18' 'gst-plugins-bad' 'gst-plugins-bad' 'gst-plugins-bad' 'gst-plugins-bad')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=gnome-shell.install
+source=("${pkgname%-git}::git+https://github.com/hslbck/gnome-shell-extension-radio.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}