summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-11-08 09:09:59 -0700
committerMark Wagie2022-11-08 09:09:59 -0700
commit262670e3bd4b7b5720ffaf9bb3b639b3af33c8f8 (patch)
treef11f7c08de6f2a7e1c9475c50555af2e3241fe58 /PKGBUILD
parentc6d77cbb1d1d3370d2ef21f7d0c711abfcebe994 (diff)
downloadaur-262670e3bd4b7b5720ffaf9bb3b639b3af33c8f8.tar.gz
add missing dep, adjust locale installation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8cada6c2c000..83e2adccec85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=gnome-shell-extension-rounded-window-corners-git
-pkgver=8.r0.g1701678
+pkgver=9.r1.g2975f5f
pkgrel=1
pkgdesc="A GNOME Shell extension that adds rounded corners for all windows"
arch=('any')
url="https://github.com/yilozt/rounded-window-corners"
license=('GPL3')
-depends=('gnome-shell')
+depends=('gnome-shell' 'libadwaita')
makedepends=('git' 'gobject-introspection' 'yarn')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -45,12 +45,9 @@ package() {
bsdtar -xvf "_build/${uuid}.shell-extension.zip" -C \
"$pkgdir/usr/share/gnome-shell/extensions/${uuid}/"
+ cp -r _build/locale "$pkgdir/usr/share/"
+
install -Dm644 _build/schemas/org.gnome.shell.extensions.rounded-window-corners.gschema.xml -t \
"$pkgdir/usr/share/glib-2.0/schemas/"
rm -rf "$pkgdir/usr/share/gnome-shell/extensions/${uuid}/schemas/"
-
- for locale in id nb_NO zh_CN; do
- install -Dm644 "_build/locale/${locale}/LC_MESSAGES/${uuid}.mo" -t \
- "$pkgdir/usr/share/locale/${locale}/LC_MESSAGES/"
- done
}