summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2023-03-01 10:49:18 -0700
committerMark Wagie2023-03-01 10:49:18 -0700
commit73f896e01b8961243e0e4e12078c727ba30d568e (patch)
tree05b44f12aa9f9835c907701418cc093ff9f1534f /PKGBUILD
parent2e5f584c34837659a5153870f0714ff7fd77edbe (diff)
downloadaur-73f896e01b8961243e0e4e12078c727ba30d568e.tar.gz
remove workaround, improve build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 4 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0cc9b7b57831..ebcd1c22c3ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=gnome-shell-extension-rounded-window-corners-git
-pkgver=10.r5.g3617ed9
+pkgver=10.r21.gd7edcd9
pkgrel=1
pkgdesc="A GNOME Shell extension that adds rounded corners for all windows"
arch=('any')
@@ -19,31 +19,12 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/rounded-window-corners"
-
- # fill_pot fails, skip for now
- # https://github.com/yilozt/rounded-window-corners/issues/101
- sed -i 's/exports.po = series(gen_pot, fill_pot, compile_po)/exports.po = series(gen_pot, compile_po)/g' gulp/po.js
-}
-
build() {
cd "$srcdir/rounded-window-corners"
yarn config set cache-folder "$srcdir/yarn-cache"
yarn install
yarn build
-# yarn ext:pack
-
- pushd _build
- gnome-extensions pack \
- --extra-source=dbus/ \
- --extra-source=effect/ \
- --extra-source=manager/ \
- --extra-source=preferences/ \
- --extra-source=utils/ \
- --extra-source=stylesheet-prefs.css \
- --force
- popd
+ yarn ext:pack
}
package() {
@@ -51,10 +32,10 @@ package() {
local uuid=$(grep -Po '(?<="uuid": ")[^"]*' _build/metadata.json)
install -d "$pkgdir/usr/share/gnome-shell/extensions/${uuid}"
- bsdtar -xvf "_build/${uuid}.shell-extension.zip" -C \
+ bsdtar -xvf "${uuid}.shell-extension.zip" -C \
"$pkgdir/usr/share/gnome-shell/extensions/${uuid}/"
- cp -r _build/locale "$pkgdir/usr/share/"
+ mv "$pkgdir/usr/share/gnome-shell/extensions/${uuid}/locale" "$pkgdir/usr/share/"
install -Dm644 _build/schemas/org.gnome.shell.extensions.rounded-window-corners.gschema.xml -t \
"$pkgdir/usr/share/glib-2.0/schemas/"