summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2021-04-14 00:31:16 -0400
committerTony Lambiris2021-04-14 00:31:16 -0400
commit1a10333b959a997966ae56da7465a499dac13e19 (patch)
treea9d948008c733732542bf4bf8d193049d5abc538 /PKGBUILD
parent852caaa481aa7424a04c8c14545adcdac9ea9036 (diff)
downloadaur-1a10333b959a997966ae56da7465a499dac13e19.tar.gz
Version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eadc9a871e9e..ffd3a70f9852 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Tony Lambiris <tony@libpcap.net>
pkgname=gnome-shell-extension-screenshot-git
-pkgver=r185.4adf8fb
+pkgver=r260.a801d40
pkgrel=1
pkgdesc="Gnome Shell extension for making and uploading screenshots"
arch=('any')
-url="https://github.com/OttoAllmendinger/gnome-shell-screenshot"
+url="https://github.com/OttoAllmendinger/gnome-shell-screenshot.git"
license=('MIT')
depends=('gnome-shell')
makedepends=('git' 'zip' 'unzip' 'eslint')
-source=("${pkgname}::git+https://github.com/OttoAllmendinger/gnome-shell-screenshot.git")
+source=("${pkgname}::git+${url}")
md5sums=('SKIP')
pkgver() {
@@ -18,15 +18,17 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${srcdir}/${pkgname}"
+
+ make update_dependencies
+}
+
package() {
cd "${srcdir}/${pkgname}"
_extid="gnome-shell-screenshot@ttll.de"
_extpath="${pkgdir}/usr/share/gnome-shell/extensions/${_extid}"
- make EXTENSION_PATH="${_extpath}" all
- install -dm755 "${_extpath}"
-
- cd "${_extpath}"
- unzip "${srcdir}/${pkgname}/gnome-shell-screenshot.zip"
+ make EXTENSION_PATH="${_extpath}" install
}