summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2017-05-26 17:48:27 -0400
committerTony Lambiris2017-05-26 17:48:27 -0400
commit27c28f0368039cf5efaee71d280c6b00ede82d58 (patch)
treeaca1ee8a64195d95fc7523950f84ed1afe8b5bb4 /PKGBUILD
downloadaur-27c28f0368039cf5efaee71d280c6b00ede82d58.tar.gz
Add new gnome-shell-extention for screen grabs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c477c98ff3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=gnome-shell-extension-screenshot-git
+pkgver=95.90b6779
+pkgrel=1
+pkgdesc="Gnome Shell extension for making and uploading screenshots"
+arch=('any')
+url="https://github.com/OttoAllmendinger/gnome-shell-screenshot"
+license=('MIT')
+depends=('gnome-shell')
+makedepends=('git')
+source=("${pkgname}::git+https://github.com/OttoAllmendinger/gnome-shell-screenshot.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd ${pkgname}
+ _extid="gnome-shell-screenshot@ttll.de"
+ _extpath="${pkgdir}/usr/share/gnome-shell/extensions/${_extid}"
+
+ make EXTENSION_PATH=${_extpath} install
+}