summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy Richardson2022-01-02 14:54:47 +0000
committerAndy Richardson2022-01-02 14:54:47 +0000
commit885bb07ea8efdb5bef8eafaa329a73821f7dbd81 (patch)
tree4526e2abc58fe88aec3f6afc93c4342e77152aaa /PKGBUILD
downloadaur-885bb07ea8efdb5bef8eafaa329a73821f7dbd81.tar.gz
Initial release (v5)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d47a4b77c518
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Andy Richardson <andy.john.richardson@gmail.com>
+pkgname=gnome-shell-extension-simply-workspaces-git
+pkgver=v5
+pkgrel=1
+pkgdesc="Gnome 3 workspace indicator with an i3/polybar style."
+arch=(any)
+licence=(GPLv3)
+
+makedepends=('git')
+source=("git+https://github.com/andyrichardson/simply-workspaces.git")
+sha256sums=('SKIP')
+provides+=("$pkgname=$pkgver")
+conflicts+=("$pkgname")
+
+prepare() {
+ git fetch origin $pkgver
+ git checkout $pkver
+}
+
+package() {
+ cd simply-workspaces
+ make PREFIX=$pkgdir/usr install
+}