summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKalle Lindqvist2020-02-17 18:14:12 +0100
committerKalle Lindqvist2020-02-17 18:14:12 +0100
commit8c424bc1044ee6abc636789bc4bab252e45d97c0 (patch)
tree44ac6cb52b7f0ec42fbf3996ec77d5f954877ad8 /PKGBUILD
parent4149b5ca3bf8845d2aefd6fb91496cfcfd1f0b6e (diff)
downloadaur-8c424bc1044ee6abc636789bc4bab252e45d97c0.tar.gz
Update to V.25
Source changed from github tarball to the zip file hosted on gnome shell extension website
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75146ad00b22..e5729acc3e10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: Kalle Lindqvist <kalle.lindqvist@mykolab.com>
pkgname=gnome-shell-extension-sound-output-device-chooser
-pkgver=24
+pkgver=25
pkgrel=1
pkgdesc="Sound Input & Output Device Chooser."
arch=('any')
url="https://github.com/kgshank/gse-sound-output-device-chooser"
license=('GPL')
depends=('gnome-shell')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/kgshank/gse-sound-output-device-chooser/archive/${pkgver}.tar.gz")
-md5sums=("3eb69f4b4e2edb0e785201cd71ab573c")
+source=("${pkgname}-${pkgver}.zip::https://extensions.gnome.org/extension-data/sound-output-device-chooserkgshank.net.v25.shell-extension.zip")
+md5sums=("c92eb48bf836f2b01a1ed66a867ac688")
package() {
_uuid="sound-output-device-chooser@kgshank.net"
- cd "${srcdir}/gse-sound-output-device-chooser-${pkgver}"
+ cd "${srcdir}"
+ rm "${pkgname}-${pkgver}.zip"
+ chmod -R 755 *
install -d "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
- cp -r "${_uuid}" "${pkgdir}/usr/share/gnome-shell/extensions/"
+ cp -r * "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/"
}