summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPieter Goetschalckx2015-10-09 11:36:06 +0200
committerPieter Goetschalckx2015-10-09 11:36:06 +0200
commitdc46a944c67f849a55e1ab787baea1118d235a15 (patch)
treee836c1f832b3d6ac2ded75391dab7fe5485338dd /PKGBUILD
parent2085da1acfd4863d3f45814e09ac0d5ff7820e50 (diff)
downloadaur-dc46a944c67f849a55e1ab787baea1118d235a15.tar.gz
Update for gnome-shell 3.18
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 10d9197bcc3e..44c68916dee0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
pkgname=gnome-shell-extension-suspend-button-git
-pkgver=r15.9321c11
+pkgver=r17.181a467
pkgrel=1
pkgdesc="Allows to modify the suspend/shutdown button in the status menu."
arch=('i686' 'x86_64')
@@ -10,14 +10,21 @@ license=('GPL')
depends=('gnome-shell')
makedepends=('git')
install=gnome-shell-extension-suspend-button.install
-source=("$pkgname::git+https://github.com/laserb/gnome-shell-extension-suspend-button")
-sha256sums=('SKIP')
+source=("$pkgname::git+https://github.com/laserb/gnome-shell-extension-suspend-button"
+ "gnome-shell-version.patch")
+sha256sums=('SKIP'
+ '02ca0deeb19b203047723361ee6f2e45ad98216a7b2462aeb1cf0ffd8c0bc9d2')
pkgver() {
cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$pkgname"
+ patch -p0 -i "$srcdir/gnome-shell-version.patch"
+}
+
package() {
cd "$pkgname"
_uuid='suspend-button@laserb'