summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrliang2017-03-10 21:36:03 -0300
committerrliang2017-03-10 21:36:03 -0300
commite75869a913692c74a4f7d6da586f361e52066e7f (patch)
treef80c907fe548b46f9ae4ea726b772b283b789a6c /PKGBUILD
downloadaur-e75869a913692c74a4f7d6da586f361e52066e7f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11e096fe2123
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ricardo Liang <ricardoliang at gmail dot com>
+pkgname=gnome-shell-extension-task-icons-git
+pkgver=r10.68ddf46
+pkgrel=1
+pkgdesc='Adds task icons grouped by workspace to the panel.'
+arch=('any')
+url="https://github.com/rliang/gnome-shell-extension-task-icons"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('git')
+optdepends=()
+conflicts=('gnome-shell-extension-task-icons')
+source=("${pkgname}::git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "${pkgname}"
+
+ local _extname="$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)"
+
+ install -Dm644 -t "${pkgdir}/usr/share/gnome-shell/extensions/${_extname}" *.js *.css metadata.json
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
+}