summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2019-01-27 10:29:50 +0000
committerLeonidas Spyropoulos2019-01-27 10:29:50 +0000
commit64920f5946be3b02ca3940cc34c502aa60d63503 (patch)
treea22c4d552c3641a209e2a97bc07b22d1eb63b182 /PKGBUILD
downloadaur-gnome-shell-extension-topicons-redux.tar.gz
TopIcons Redux version 6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19d9714d03f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Leonidas spyropoulos <artafinde AT gmail DOT com>
+
+pkgname=gnome-shell-extension-topicons-redux
+_projectName=TopIcons-Redux
+pkgver=6
+pkgrel=1
+pkgdesc='TopIcons Redux is a fork of TopIcons Plus'
+arch=('any')
+url="https://gitlab.com/pop-planet/${_projectName}"
+license=('GPL')
+depends=('gnome-shell')
+makedepends=('git')
+provides=('gnome-shell-extension-topicons-redux')
+groups=('gnome-shell-extensions')
+source=("git+https://gitlab.com/pop-planet/${_projectName}.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd "${_projectName}"
+ make build
+}
+
+package() {
+ cd "${_projectName}"
+ local uuid=$(grep -Po '(?<="uuid": ")[^"]*' _build/metadata.json)
+ local destdir="$pkgdir/usr/share/gnome-shell/extensions/$uuid"
+ install -dm755 "$destdir"
+ cp -r _build/* "$destdir"
+}