summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Schendel2022-03-14 11:12:52 +0100
committerChristian Schendel2022-03-14 11:12:52 +0100
commit0c1de40c237c92236b4a9c814a3ccf6fff327803 (patch)
tree632fdfe36600b69e63483b0159722ecef1a34405 /PKGBUILD
parent58efa525e7e11943ca2ddbded24d79733dd8c0ca (diff)
downloadaur-0c1de40c237c92236b4a9c814a3ccf6fff327803.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e73e22c77fa3..90b9e4aee95e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Christian Schendel <doppelhelix at gmail dot com>
pkgname=gnome-shell-extension-useless-gaps-git
-pkgver=r14.672d14e
-pkgrel=2
+pkgver=r18.e5029a3
+pkgrel=1
pkgdesc="Useless Gaps is a GNOME Shell Extension which for aesthetic purposes adds 'useless gaps' around windows."
arch=(any)
url="https://github.com/mipmip/gnome-shell-extensions-useless-gaps"
install=${pkgname%-git}.install
license=('GPL3')
depends=('gnome-shell>=40')
-makedepends=('git' 'glib2' 'gettext')
+makedepends=('git'
+ 'glib2'
+ 'gettext')
conflicts=("${pkgname%-git}")
provides=(${pkgname%-git})
source=("${pkgname%-git}::git+${url}.git")
@@ -50,5 +52,9 @@ package() {
cp -r * "${destdir}"
install -Dm644 "schemas/${schema}" \
"${pkgdir}/usr/share/glib-2.0/schemas/${schema}"
+# rebuild compiled GSettings schemas if missing
+ if [[ ! -f "${destdir}/schemas/gschemas.compiled" ]]; then
+ glib-compile-schemas "${destdir}/schemas"
+ fi
}