summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormschubert2015-06-12 12:10:21 +0100
committermschubert2015-06-12 12:10:21 +0100
commit76991cda9fafe67f63b96c36700af2248cb9d681 (patch)
tree3f2e88f361cdd35b9da0614ef237cae20cd05eca /PKGBUILD
downloadaur-76991cda9fafe67f63b96c36700af2248cb9d681.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec7ed8fea535
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Christian METZLER <neroth@xeked.com>
+pkgname=gnome-shell-extension-weather-git
+_pkgname=${pkgname%-git}
+pkgver=r572.329139f
+pkgrel=1
+epoch=1
+pkgdesc="A simple GNOME Shell extension for displaying weather informations from several cities"
+arch=('any')
+url="https://github.com/Neroth/gnome-shell-extension-weather"
+license=('GPL3')
+depends=('dconf' 'gettext' 'pkg-config')
+makedepends=('git' 'gnome-common' 'autoconf' 'automake' 'intltool')
+replaces=('gnome-shell-extension-weather-neroth-git')
+install='gschemas.install'
+source=("git+https://github.com/Neroth/gnome-shell-extension-weather")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
+}