summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPieter Goetschalckx2018-10-09 09:16:17 +0200
committerPieter Goetschalckx2018-10-09 09:16:17 +0200
commit1cbfa9e9baa3774d783a806ff54effb59e290edd (patch)
tree0f7da50206086923788ca8f6e5ef5c05a639bf20 /PKGBUILD
parent1f1f9ab20b9e9cd6f820a9ddc9eb51d66ed61434 (diff)
downloadaur-1cbfa9e9baa3774d783a806ff54effb59e290edd.tar.gz
Fix for gnome-shell 3.30
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db74e86f18a1..f6e1d97cc6fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Foivos S. Zakkak <foivos at zakkak dot net>
pkgname=gnome-shell-extension-workspace-grid-git
-pkgver=1.5.17
+pkgver=1.6.0.r212.d20f11a
pkgrel=1
pkgdesc="Allows to configure your workspaces in a grid"
arch=(any)
@@ -16,31 +16,35 @@ sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
- git describe --long --tags | sed -r 's/^v//;s/([^-]*)-g.*$/\1/;s/-/./g'
+ printf "1.6.0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$pkgname"
+ cd "$pkgname/src"
_uuid='workspace-grid@mathematical.coffee.gmail.com'
- install -Dm644 "${_uuid}/metadata.json" \
+ install -Dm644 "metadata.json" \
"${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/metadata.json"
- install -m644 "${_uuid}/extension.js" \
+ install -m644 "extension.js" \
"${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/extension.js"
- install -m644 "${_uuid}/utils.js" \
+ install -m644 "utils.js" \
"${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/utils.js"
- install -m644 "${_uuid}/convenience.js" \
+ install -m644 "convenience.js" \
"${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/convenience.js"
- install -m644 "${_uuid}/prefs.js" \
+ install -m644 "prefs.js" \
"${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/prefs.js"
- install -m644 "${_uuid}/stylesheet.css" \
+ install -m644 "prefKeys.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/prefKeys.js"
+ install -m644 "version.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/version.js"
+ install -m644 "stylesheet.css" \
"${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/stylesheet.css"
- install -m644 "${_uuid}/ws-switch-arrow-left.png" \
+ install -m644 "ws-switch-arrow-left.png" \
"${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/ws-switch-arrow-left.png"
- install -m644 "${_uuid}/ws-switch-arrow-right.png" \
+ install -m644 "ws-switch-arrow-right.png" \
"${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/ws-switch-arrow-right.png"
- install -m644 "${_uuid}/myWorkspaceSwitcherPopup.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/myWorkspaceSwitcherPopup.js"
- install -Dm644 "${_uuid}/schemas/org.gnome.shell.extensions.workspace-grid.gschema.xml" \
+ install -m644 "gridWorkspaceSwitcherPopup.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/gridWorkspaceSwitcherPopup.js"
+ install -Dm644 "schemas/org.gnome.shell.extensions.workspace-grid.gschema.xml" \
"${pkgdir}/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.workspace-grid.gschema.xml"
}