summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGT6102023-05-01 20:05:24 +0800
committerGT6102023-05-01 20:05:24 +0800
commit5c3117681a553968d22b01fb8386b874dda8debe (patch)
tree42b5b19454b9080ae8916aa3eca45574c3b2f9bb /PKGBUILD
parentcc544b174c47172c504570c3e066dea80a6ab720 (diff)
downloadaur-5c3117681a553968d22b01fb8386b874dda8debe.tar.gz
Change the source to the source code and update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b81263dc3e92..f444aec0b2e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,26 @@
+#Maintainer: GT610 <myddz1005@163.com>
+
pkgname=gnome-shell-extension-zorin-taskbar
-pkgver=1.4.4_all
+_name=zorin-taskbar
+pkgver=40.20
pkgrel=1
pkgdesc="Various settings and changes for the panel in Zorin Desktop."
-arch=('i686' 'x86_64')
-url="http://zorinos.com/"
-license=('GPL-2+')
+arch=('any')
+url="https://github.com/ZorinOS/zorin-taskbar"
+license=('GPL-2.0')
depends=('gnome-shell')
options=('!emptydirs' '!strip')
install=${pkgname}.install
-source=('http://ppa.launchpad.net/zorinos/stable/ubuntu/pool/main/g/gnome-shell-extension-zorin-taskbar/gnome-shell-extension-zorin-taskbar_1.4.4_all.deb')
-md5sums=('fac07f2f5ab100075b3563248fe4adf1')
+source=(${_name}-${pkgver}.tar.gz::https://github.com/ZorinOS/${_name}/archive/refs/tags/${pkgver}.tar.gz)
+md5sums=('6c7d47fc8021dd2e5fca1871595ee2a4')
+sha256sums=('b88c44dfc50fed9f20da2adff52245c41c6a5df7d3ddd6fba2c2f5a8077472af')
+
+build() {
+ cd "${srcdir}"/${_name}-${pkgver}
+ make
+}
package() {
- msg2 "Extracting the data.tar.xz..."
- bsdtar -xf data.tar.xz -C "$pkgdir/"
+ cd "${srcdir}"/${_name}-${pkgver}
+ make DESTDIR="${pkgdir}" VERSION="${pkgver}" install
}
-