summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSaren Arterius2018-12-13 01:43:14 +0800
committerSaren Arterius2018-12-13 01:43:14 +0800
commita36fa923ce6b7cfce0e0e1c7a925959c12bddaf1 (patch)
tree21292d8f98df0ba6aededfc8a8bf1a74f4ba32b7 /PKGBUILD
parentf7bd9adb53c71b96e8e1e5043c399fbfd3594af9 (diff)
downloadaur-a36fa923ce6b7cfce0e0e1c7a925959c12bddaf1.tar.gz
detect mutter-781835-workaround before applying MR276
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 281463488026..797417c464b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=gnome-shell-performance
_pkgname=gnome-shell
-pkgver=3.30.2+3+g6ff7805c0
+pkgver=3.30.2+4
pkgrel=1
pkgdesc="Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches"
url="https://wiki.gnome.org/Projects/GnomeShell"
@@ -27,11 +27,6 @@ source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
sha256sums=('SKIP'
'SKIP')
-pkgver() {
- cd $_pkgname
- git describe --tags | sed 's/-/+/g'
-}
-
prepare() {
cd $_pkgname
@@ -39,12 +34,21 @@ prepare() {
# https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/224
git remote add vanvugt https://gitlab.gnome.org/vanvugt/gnome-shell.git || true
git fetch vanvugt
- git cherry-pick 6a3dd0fa || bash
- git cherry-pick 5aac3f0a || bash
+ git cherry-pick 6a3dd0fa
+ git cherry-pick 5aac3f0a
- # js/ui: Use captured-event::instantaneous [performance]
+ # js/ui: Use captured-event::instantaneous [performance]
# https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/276
- git cherry-pick d12c86cf || bash
+ # Requires mutter MR283/commit "clutter-actor: Add detail to captured-event signal [performance]"
+ pacman -Q | grep mutter-781835-workaround
+ if [ $? -eq 0 ]; then
+ git cherry-pick d12c86cf || bash
+ echo "======= mutter-781835-workaround detected, MR276 is applied ======="
+ sleep 3
+ else
+ echo "======= mutter-781835-workaround not installed, not applying MR276 ======="
+ sleep 3
+ fi
# Move the plugin to our custom epiphany-only dir
sed -i "s/'mozilla'/'epiphany'/g" meson.build