summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSaren Arterius2018-08-30 22:37:55 +0800
committerSaren Arterius2018-08-30 22:37:55 +0800
commitcab3394bde4d743371d98bc14e1d4624f620bae2 (patch)
treeee69da5b465fd4af84d16a69c895b8f79cb122d2 /PKGBUILD
parent89effc3c21a161c23e417ce8ff4b449ae3608a61 (diff)
downloadaur-cab3394bde4d743371d98bc14e1d4624f620bae2.tar.gz
update upstream, update commit, add tweener fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 819f3baa1e88..64b93338c19c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=gnome-shell-performance
_pkgname=gnome-shell
-pkgver=3.28.3
-pkgrel=2
+pkgver=3.28.3+7+g721ce5403
+pkgrel=1
pkgdesc="The next generation GNOME Shell | Attempt to improve the performance by non-upstreamed patches"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch=(x86_64)
@@ -20,7 +20,7 @@ optdepends=('gnome-control-center: System settings'
groups=(gnome)
provides=(gnome-shell)
conflicts=(gnome-shell)
-_commit=6ed21e1ce0c1011b58452df6cdde42f30dd386c4 # tags/3.28.3^0
+_commit=721ce54037cc07a82927cfdfb7928dadad7d7791 # gnome-3-28
source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
fix.diff)
@@ -31,10 +31,22 @@ sha256sums=('SKIP'
prepare() {
cd $_pkgname
+ # js/ui: Choose some actors to cache on the GPU
# https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/73/commits
git remote add vanvugt https://gitlab.gnome.org/vanvugt/gnome-shell.git || true
git fetch vanvugt
- git cherry-pick 6e838439 || bash
+ git cherry-pick f77b3da7 || bash
+
+ # Javascript invalid access fixes
+ # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/4/commits
+ git remote add vanvugt https://gitlab.gnome.org/vanvugt/gnome-shell.git || true
+ git fetch vanvugt
+ git cherry-pick 78da92c1 || bash
+ git cherry-pick df5ca834 || bash
+ git cherry-pick a667357e || bash
+ git cherry-pick 163e9b43 || bash
+ git cherry-pick 1f820518 || bash
+
# Try to fix docs build
patch -Np1 -i ../fix.diff