summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTérence Clastres2019-03-16 16:43:10 +0100
committerTérence Clastres2019-03-16 16:47:53 +0100
commitcb588bfe3f4228c79fb1c8b5d30c751bd3c604ae (patch)
tree95500e78d0d13e058e97e81dcf7a4fbb1c991926 /PKGBUILD
parent80d1d29586349aa04941a26ffcc339eb2ea15e09 (diff)
downloadaur-cb588bfe3f4228c79fb1c8b5d30c751bd3c604ae.tar.gz
Restore conditional performance patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 14 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 137504deb007..21b75dca6c7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Flamelab <panosfilip@gmail.com
pkgname=gnome-shell-performance
-pkgver=3.32.0+15+gb7d79a5f0
+pkgver=3.32.0+16+gc5780056a
pkgrel=1
pkgdesc="Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches"
url="https://wiki.gnome.org/Projects/GnomeShell"
@@ -32,6 +32,19 @@ pkgver() {
prepare() {
cd $pkgname
+
+ # js/ui: Use captured-event::nonmotion [performance]
+ # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/276
+ # Requires mutter MR283/commit "clutter-actor: Add detail to captured-event signal [performance]"
+ if pacman -Q | grep mutter-781835-workaround; then
+ git cherry-pick 297a18f2
+ echo "======= mutter-781835-workaround detected, MR276 is applied ======="
+ sleep 3
+ else
+ echo "======= mutter-781835-workaround not installed, not applying MR276 ======="
+ sleep 3
+ fi
+
git submodule init
git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
git submodule update