summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSaren Arterius2018-09-18 10:17:53 +0800
committerSaren Arterius2018-09-18 10:17:53 +0800
commite9a4606954be264fcd51a4fdc30ee2e187363477 (patch)
treeeea96b300b96de75bb1f4ca9d9ec02c763d934c5 /PKGBUILD
parentbc63320b981716839bcb4f724e79f778463bfd3f (diff)
downloadaur-e9a4606954be264fcd51a4fdc30ee2e187363477.tar.gz
3.30
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 16 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 85491618f6f9..42b6812078da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# $Id$
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Patched package maintainer: Saren Arterius <saren@wtako.net>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Flamelab <panosfilip@gmail.com
pkgname=gnome-shell-performance
_pkgname=gnome-shell
-pkgver=3.28.3+7+g721ce5403
-pkgrel=2
-pkgdesc="The next generation GNOME Shell | Attempt to improve the performance by non-upstreamed patches"
+pkgver=3.30.0+21+gb087752b5
+pkgrel=1
+pkgdesc="Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch=(x86_64)
license=(GPL2)
@@ -20,36 +21,21 @@ optdepends=('gnome-control-center: System settings'
groups=(gnome)
provides=(gnome-shell)
conflicts=(gnome-shell)
-_commit=721ce54037cc07a82927cfdfb7928dadad7d7791 # gnome-3-28
+_commit=b087752b5539a8cbb1d61979cb069aef8a3475be # master
source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
- fix.diff)
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
sha256sums=('SKIP'
- 'SKIP'
- '11dcffae170776140b1f0c9bed90b8df70e8d3c6694b60ab40bb46235e3ad755')
+ 'SKIP')
-prepare() {
+pkgver() {
cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
- # js/ui: Choose some actors to cache on the GPU
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/73/commits
- git remote add vanvugt https://gitlab.gnome.org/vanvugt/gnome-shell.git || true
- git fetch vanvugt
- git cherry-pick f77b3da7 || bash
-
- # Javascript invalid access fixes
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/4/commits
- # git remote add vanvugt https://gitlab.gnome.org/vanvugt/gnome-shell.git || true
- # git fetch vanvugt
- # git cherry-pick 78da92c1 || bash
- # git cherry-pick df5ca834 || bash
- # git cherry-pick a667357e || bash
- # git cherry-pick 163e9b43 || bash
- # git cherry-pick 1f820518 || bash
-
+prepare() {
+ cd $_pkgname
- # Try to fix docs build
- patch -Np1 -i ../fix.diff
+ # No patches as of now
# Move the plugin to our custom epiphany-only dir
sed -i "s/'mozilla'/'epiphany'/g" meson.build
@@ -65,9 +51,9 @@ build() {
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" meson install -C build
- # Must exist; FS#37412
+ # https://bugs.archlinux.org/task/37412
mkdir "$pkgdir/usr/share/gnome-shell/modes"
}