summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGordian Edenhofer2015-05-23 14:09:31 +0200
committerGordian Edenhofer2015-05-23 14:09:31 +0200
commita34e7a12c4a783c630802e0ed42501232682b75e (patch)
tree72f0906159df1a65b1788f49a0850b0799923434 /PKGBUILD
downloadaur-a34e7a12c4a783c630802e0ed42501232682b75e.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea72f481a521
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
+
+pkgname=gnome-shell-theme-copernico-git
+_pkgname=copernico
+pkgver=7.bc76060
+pkgrel=1
+pkgdesc="A theme for the GNOME Shell which provides a slightly more pleasant visual impression."
+arch=('any')
+url="http://gnome-look.org/content/show.php/Copernico+Theme?content=167439"
+license=('GPL3')
+depends=('gtk3' 'gnome-shell')
+makedepends=('git')
+source=(${_pkgname}::'git+https://bitbucket.org/mgyugcha/copernico-theme.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -dm755 "${pkgdir}/usr/share/themes/${_pkgname}"
+ rm -rf {.git,images,LICENSE.txt,README.md}
+ cp -dpr --no-preserve=ownership . "${pkgdir}/usr/share/themes/${_pkgname}/"
+}