summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLubosz Sarnecki2022-11-04 13:22:31 +0100
committerLubosz Sarnecki2022-11-04 15:30:39 +0100
commit144c98682705f2f522da06a7553b0dcc72769a06 (patch)
tree4f1c4efb43dc435ee35810ce8400e402b4585403 /PKGBUILD
parent20ae0a83ee5474fe0c2ad7cafc0c713c80d6c5fc (diff)
downloadaur-144c98682705f2f522da06a7553b0dcc72769a06.tar.gz
Bump to version 43.0.
Pull updates from arch pkgbuild.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 23 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c83dbe25b11f..e98a52f05230 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
basename=gnome-shell
pkgname=$basename-xrdesktop-git
-pkgver=42.5
+pkgver=43.0
pkgrel=1
epoch=1
conflicts=($basename)
@@ -14,42 +14,52 @@ pkgdesc="Next generation desktop shell - with patches for xrdesktop."
url="https://gitlab.freedesktop.org/xrdesktop"
arch=(x86_64)
license=(GPL)
-depends=(accountsservice gcr gjs gnome-bluetooth upower gnome-session gtk4
- gnome-settings-daemon gnome-themes-extra gsettings-desktop-schemas
- libcanberra-pulse libgdm libsecret mutter nm-connection-editor unzip
- gstreamer libibus gnome-autoar gnome-disk-utility gst-plugin-pipewire
- xrdesktop-git libinputsynth-git)
+depends=(accountsservice gcr-4 gjs upower gnome-session gtk4
+ gnome-settings-daemon gsettings-desktop-schemas libcanberra-pulse
+ libgdm libsecret mutter libnma unzip libibus gnome-autoar
+ gnome-disk-utility libsoup3 libgweather-4 xrdesktop-git libinputsynth-git)
makedepends=(gtk-doc gnome-control-center evolution-data-server
gobject-introspection git meson sassc asciidoc bash-completion)
checkdepends=(xorg-server-xvfb)
optdepends=('gnome-control-center: System settings'
- 'evolution-data-server: Evolution calendar integration')
+ 'evolution-data-server: Evolution calendar integration'
+ 'gst-plugins-good: Screen recording'
+ 'gst-plugin-pipewire: Screen recording'
+ 'gnome-bluetooth-3.0: Bluetooth support')
groups=(gnome)
provides=(gnome-shell=$pkgver)
-source=("git+https://gitlab.freedesktop.org/xrdesktop/gnome-shell.git#branch=42.5-xrdesktop"
+options=(debug)
+_branch="43.0-xrdesktop" # tags/43.0^0
+source=("git+https://gitlab.freedesktop.org/xrdesktop/gnome-shell.git#branch=${_branch}"
"git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
sha256sums=('SKIP'
'SKIP')
pkgver() {
- cd $basename
+ cd gnome-shell
grep -Po "(?<=^ version: ')((\d+\.)+\d+)" meson.build
}
prepare() {
- cd $basename
+ cd gnome-shell
git submodule init
git submodule set-url subprojects/gvc "$srcdir/libgnome-volume-control"
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
build() {
- arch-meson $basename build -D gtk_doc=true --buildtype=release
+ CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
+ LDFLAGS+=" -Wl,-Bsymbolic-functions"
+
+ arch-meson gnome-shell build -D gtk_doc=true
meson compile -C build
}
package() {
- depends+=(libmutter-10.so)
+ depends+=(libmutter-11.so)
meson install -C build --destdir "$pkgdir"
}
+
+# vim:set sw=2 sts=-1 et:
+