summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMitchell Renouf2018-10-17 18:33:54 -0230
committerMitchell Renouf2018-10-17 18:33:54 -0230
commit037e565cc2f1a5196b045b443fbcc46389413759 (patch)
tree33a5b4b443875fa31871cdc8b69c360f163a42d1 /PKGBUILD
parent286de87072f51692c9471ba0b549c902313a37ad (diff)
downloadaur-037e565cc2f1a5196b045b443fbcc46389413759.tar.gz
Switch to checksumed tarball
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3f3a2c1db7ed..79e13501e42a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,21 +12,17 @@ arch=(x86_64)
license=(GPL2)
makedepends=(appstream-glib gnome-desktop libpackagekit-glib flatpak fwupd ostree
docbook-xsl git gobject-introspection gspell gtk-doc meson valgrind snapd-glib)
-_commit=035e0f7459d5b0eaafd120b88f3b8b39bbb5ef2a # tags/3.30.2^0
-source=("git+https://gitlab.gnome.org/GNOME/gnome-software.git#commit=$_commit")
-sha256sums=('SKIP')
+source=("$_pkgbase-$pkgver.tar.gz::https://gitlab.gnome.org/GNOME/gnome-software/-/archive/$pkgver/gnome-software-$pkgver.tar.gz")
+sha256sums=('b709a4408da8225d982751f13c4e3ada2dfd453a4ccdd01f0da3040d4de3d542')
+
-pkgver() {
- cd $_pkgbase
- git describe --tags | sed 's/^GNOME_SOFTWARE_//;s/_/./g;s/-/+/g'
-}
prepare() {
- cd $_pkgbase
+ cd $_pkgbase-$pkgver
}
build() {
- arch-meson $_pkgbase build \
+ arch-meson $_pkgbase-$pkgver build \
-D ubuntuone=true \
-D ubuntu_reviews=true \
-D snap=true